[ROR]bundle install 에러질문입니다.


  • Level 9

    현재 ruby 버전은 2.6.3
    rails 버전은 5.2.3 입니다.
    bundle install 명령어시

    36a1c271-8494-479d-908a-5803e10aa6e8-image.png

    라며 에러가납니다. pg젬을 설치시,

    6356081b-d1bd-4881-b076-980eefe96a8c-image.png

    같은 에러가 납니다. 이럴때 어떻게 해야할까요?

  • Level 9

    혼자 해결했습니다!
    현재 디렉토리내에서 pg젬의 버전을 자동으로 찾아주지 못해 발생하는 문제였어요.
    현재 개발환경은 우분투18.04 버전인데 해결방법은 다음과 같습니다.

    상위디렉토리로 이동후,
    sudo apt-get install postgresql
    sudo pat-get install libpq-dev

    한다음 다시 원래 디렉토리로 돌아가
    bundle install
    하면 자동으로 pg젬을 찾아깔아줍니다

  • DevelUP HQ
    Level 10

    명령어에 적힌대로
    gem install pg -v '1.1.4' --source 'https://rubygems.org/' 를 입력해보세요!

    그러고 안되면 postgresql 프로그램이 안 깔린거니 그 프로그램을 먼저 설치해보시면 됩니다.

    postgresql 까실 때 주의할 점은 gui에서 까시지 마시고 cli 환경에서 명령어를 통해서 까는게 더 설정하기 편하실거에요

ONLINE USERS

POPULAR TOPICS

SUGGESTED TOPICS