goorm ide에서 mysqli_connect를 사용 할 때 주소랑 아이디를 어떻게 입력해야하나요?


  • Level 4

    goorm ide에서 mysqli_connect를 사용 할 때 주소랑 아이디를 어떻게 입력해야하나요?

    $conn = mysqli_connect("localhost", "root","");
    

    이렇게 입력 했을 때 작동하지 않았습니다.

  • Level 4

    @김철수 네 비번하고는 상관이 없었는데 해결되었습니다!
    제가 phpmyadmin을 설치해서 사용하고 있었는데 root 대신 phpmyadmin을 입력하고 비번을 입력하니 동작하네요 감사합니다!

  • Level 8

    @조은길 혹시 root 비밀번호를 수정하신 후 실행해보실 수 있나요? 몇몇 프레임워크에서는 root 비밀번호가 없으면 아무것도 안하는 경우가 있어서요;

  • Level 4

    @쿠키모카 mysql은 정상적으로 설치되었습니다.

  • Level 4

    @Jose-goorm 특별한 에러메세지가 출력되지는 않고 데이터가 있으나 출력 코드로 출력 되지 않습니다. 그래서 데이터 베이스 주소를 잘 못 입력했는지 궁금했습니다.
    생활코딩문제를 풀고 있는데 어렵네요. 아래 코드가 실행되지 않습니다.

    <?php
    $conn = mysqli_connect("localhost", "root","");
    mysqli_select_db($conn, "phpmyadmin");
    $result = mysqli_query($conn, "SELECT * FROM opentutorials");
        while( $row = mysqli_fetch_assoc($result)){
          echo '<li><a href="http://localhost/index.php?id='.$row['id'].'">'.$row['title'].'</a></li>'."\n";
    	}
    ?>
    
  • Level 11

    작동이 어떻게 안되셨나요?

    Access denied for user 'root'@'localhost' ~~~~~ 등의 에러가 발생하는 권한문제라면, mysql 콘솔에서

    GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' WITH GRANT OPTION; 쿼리 실행하셔서 권한 부여해보시기 바랍니다.

  • Level 5

    php7.3-mysql 설치되어있는지 먼저 확인해보세용!
    여기 도움말 있어용
    https://help.goorm.io/ko/goormide/18.faq/language-and-environment/mysqli-does-not-work

ONLINE USERS

POPULAR TOPICS

SUGGESTED TOPICS

  • 3
  • 3
  • 5
  • 2
  • 1
  • 2
  • 5
  • 3