ubuntu apt 설치 제대로 되지가 않습니다.


  • Level 2

    root@goorm:~# apt-get install cmake
    패키지 목록을 읽는 중입니다... 완료
    의존성 트리를 만드는 중입니다
    상태 정보를 읽는 중입니다... 완료
    이 상황을 바로잡으려면 'apt --fix-broken install'을 실행해야 할 수도 있습니다.
    다음 패키지의 의존성이 맞지 않습니다:
    cmake : 의존: cmake-data (= 3.16.3-1ubuntu1) 하지만 설치하지 않습니다
    의존: libjsoncpp1 (>= 1.7.4) 하지만 설치하지 않습니다
    의존: librhash0 (>= 1.2.6) 하지만 설치하지 않습니다
    cuda-drivers-515 : 의존: nvidia-compute-utils-515 (>= 515.48.07) 하지만 설치하지 않습니다
    의존: nvidia-utils-515 (>= 515.48.07) 하지만 설치하지 않
    nvidia-driver-515 : 의존: nvidia-compute-utils-515 (= 515.48.07-0ubuntu1) 하
    의존: nvidia-utils-515 (= 515.48.07-0ubuntu1) 하지만 설
    추천: libnvidia-compute-515:i386 (= 515.48.07-0ubuntu1)
    추천: libnvidia-decode-515:i386 (= 515.48.07-0ubuntu1)
    추천: libnvidia-encode-515:i386 (= 515.48.07-0ubuntu1)
    추천: libnvidia-fbc1-515:i386 (= 515.48.07-0ubuntu1)
    추천: libnvidia-gl-515:i386 (= 515.48.07-0ubuntu1)
    E: 의존성이 맞지 않습니다. 패키지 없이 'apt --fix-broken install'을 시도해 보
    십시오(아니면 해결 방법을 지정하십시오

    root@goorm:~# apt --fix-broken install
    받기:1 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64 nvidia-compute-utils-515 515.48.07-0ubuntu1 [271 kB]
    받기:2 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64 nvidia-utils-515 515.48.07-0ubuntu1 [337 kB]
    0초에 607 kB 받음 (10.9 MB/s)
    debconf: 프론트엔드를 초기화할 수 없음: Dialog
    debconf: (dialog나 그와 비슷한 프로그램을 설치하지 않았으므로, 다이얼로그 프론트엔드는 사용할 수 없습니다. at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 76, <> line 2.)
    debconf: 다음 프론트엔드를 대신 사용: Readline
    (데이터베이스 읽는중 ... 현재 92382개의 파일과 디렉터리가 설치되어 있습니다.)
    Preparing to unpack .../nvidia-compute-utils-515_515.48.07-0ubuntu1_amd64.deb ...
    Unpacking nvidia-compute-utils-515 (515.48.07-0ubuntu1) ...
    dpkg: error processing archive /var/cache/apt/archives/nvidia-compute-utils-515_515.48.07-0ubuntu1_amd64.deb (--unpack):
    새 버전을 설치하기 전 ./usr/bin/nvidia-cuda-mps-control'의 백업 링크를 만들 수 없습니다: 부적절한 장치간 연결 dpkg-deb: 오류: 붙여넣기 서브프로세스가 시그널 (파이프가 깨어짐)에 의해 죽었습니다 Preparing to unpack .../nvidia-utils-515_515.48.07-0ubuntu1_amd64.deb ... Unpacking nvidia-utils-515 (515.48.07-0ubuntu1) ... dpkg: error processing archive /var/cache/apt/archives/nvidia-utils-515_515.48.07-0ubuntu1_amd64.deb (--unpack): 새 버전을 설치하기 전./usr/bin/nvidia-debugdump'의 백업 링크를 만들 수 없습니다: 부적절한 장치간 연결
    dpkg-deb: 오류: 붙여넣기 서브프로세스가 시그널 (파이프가 깨어짐)에 의해 죽었습니다
    처리하는데 오류가 발생했습니다:
    /var/cache/apt/archives/nvidia-compute-utils-515_515.48.07-0ubuntu1_amd64.deb
    /var/cache/apt/archives/nvidia-utils-515_515.48.07-0ubuntu1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

SUGGESTED TOPICS

  • 2
  • 2
  • 2
  • 5
  • 3
  • 6
  • 6
  • 3